Apple Updates macOS High Sierra With Patches for Two Critical Flaws

Apple's recently released High Sierra operating system is patched for flaws in the keychain password service and APFS filesystem.

1088_HighSierraUpdate

Apple released an update for macOS High Sierra on Oct. 5, patching two critical vulnerabilities in the new operating system.

The security update for macOS come less than two weeks after Apple released High Sierra on Sept. 25. The initial High Sierra release patched 43 vulnerabilities, though it apparently missed the two that have now been fixed in the supplemental update.

"Apple has released a supplemental security update to address vulnerabilities in macOS High Sierra 10.13," US-CERT warned in an advisory. "An attacker could exploit these vulnerabilities to obtain sensitive information."

One of the flaws fixed in the supplemental update is a critical issue that could have enabled an attacker to steal passwords from the macOS keychain. The keychain is a service where users can store passwords for different websites and applications.

"A method existed for applications to bypass the keychain access prompt with a synthetic click," Apple warned in its advisory. "This was addressed by requiring the user password when prompting for keychain access."

The keychain flaw is identified as CVE-2017-7150 and was reported to Apple by Synack security researcher Patrick Wardle. Wardle publicly demonstrated the vulnerability in a video he released on Sept. 25.

"On High Sierra (unsigned) apps can programmatically dump & exfil keychain (w/ your plaintext passwords)," Wardle wrote in a Twitter message.

In a blog post, Wardle noted that he contacted Apple's product security team via email and text in early September, providing details of the flaw.

"I think it is important to note that I did not release any technical details of the vulnerability," Wardle wrote. "My goal of posting the video was to raise awareness of the fact that High Sierra was shipped with an exploitable vulnerability—so we can all take necessary precautions."

StorageKit

The second critical issue that Apple patched in the supplemental update for macOS High Sierra is a flaw in the StorageKit library identified as CVE-2017-7149.

"If a hint was set in Disk Utility when creating an APFS encrypted volume, the password was stored as the hint," Apple warned in its advisory. "This was addressed by clearing hint storage if the hint was the password, and by improving the logic for storing hints."

APFS is the new Apple File System that debuted in High Sierra, replacing the decade-old HFS+ filesystem that had been in used in prior macOS releases. The CVE-2017-7149 vulnerability was reported to Apple by security researcher Matheus Mariano of Leet Tech. In a blog post, Mariano detailed how he simply found the vulnerability while testing out High Sierra. 

"I really don’t know how this went unnoticed by Apple (and anyone else)," Mariano wrote.

Sean Michael Kerner is a senior editor at eWEEK and InternetNews.com. Follow him on Twitter @TechJournalist.

Sean Michael Kerner

Sean Michael Kerner

Sean Michael Kerner is an Internet consultant, strategist, and contributor to several leading IT business web sites.